Special !



Mobile version of
the aldweb Site

m.aldweb.com


Neither French, nor English?

Try one of these flags then:
[de] [es] [it] [pt]
aldweb

Close I. aldweb

Close II. PC Freeware

Close III. Palm Freeware

Close IV. Palm Shareware

Close V. iziBasic Palm

Close VI. Palm Knowledge

Close VII. Pocket Computer

Close VIII. miniPortail

Geolocation
Search




Weather / Spam / www

Lyon Weather


aldweb against spam


Newsletter
To receive news about this website, consider subscribing to our Newsletter.
Subscribe
Unsubscribe
293 Subscribers
Family's web sites

Webmaster - Infos
Poll
What do you think of the new design of the aldweb Site?
 
Great !
Beautiful
Average
So ugly...
Results
Visits

   visitors

   visitors online

Friends News
Pagerank

Google Ads
forum.gifForum - Pocket Computer - Topic #1565

Forum - Forum
Pocket Computer - Pocket Computer


active  Topic # 1565  problem to transfert file PC-->1360

27/07/2007 @ 13:11
by charognard

Anonymous



i don't receive the cr of lf on PC1360, it do a error 4 and download just a first line.
it don't receive the last code &1A too
do you have this problem and the solution

is the same problem on my pc 1600 but it accept the line without lf or cr

thanks !!
Write to charognard   Post an answer  Top

[]   

Answer n° 1
--------
27/07/2007 @ 15:13
by aldweb

Anonymous

visitor
Hello charognard,

Usually, for serial transfer, there is an option in every application to tell what to do with CR and LF.

What transfer system (cable & Big PC software) do you use?

Cheers,
aldweb
Write to aldweb   Post an answer  Top
Answer n° 2
--------
27/07/2007 @ 15:22
by charognard

Anonymous

visitor
Merci pour ta reponse, je continue en français
je possede un PC 1600 et un pc 1360.
un boitier de connection (ce-137) me permet de me relier au port serie de l'ordinateur
si en envoi du PC 1360 et 1600 --> PC (86) pas de problème je reçois bien.
mais en émission, j'ai beau coché envoie d'un CR en fin de ligne et d'un &1A en fin de transmission le PC 1360 et 1600 n'en reçois pas.
si le 1600 s'en satisfait (je suis quand même obliger de mettre un caractère &1a en fin de programme) le 1360 n'en n'a cure, et si le programme suivant passe sans problème
10 print
&1A

ceux en plusieurs lignes
10 print
20 print
&1A

me génère une erreur 4 (to large ligne number) et seule la premiere ligne est chargée.

j'ai essayer de paramétré l'open avec Cr lf et cr+lf mais rien n'y fait
de plus si au départ je pouvais incriminer vista/l'adaptateur usb j'ai testé ce matin sur XP et directement sur l' rs232 et même symtome, je teste ce soir sur un 98 mais je me rappelle que lors de la connection au 1600 j'avais du mettre le code &1a à la fin de mon fichier pour que le PC 1600 finisse son load donc j'ai bien peur que les symtome soit les même.

avec vous une solution ?
l'adaptateur CE 134 à t'il un problème ?
une configuration à faire ?

merci par avance
Write to charognard   Post an answer  Top
Answer n° 3
--------
27/07/2007 @ 15:29
by charognard

Anonymous

visitor
precision :
j'utilise hyper terminal et aussi pocketasm et les deux ont le meme syntome.
je suis d'ailleur obligé d'inserer le caractère --> (chr$(&1a)) en fin d'un fichier à transmettre sinon le PC 1360/1600 ne me rends jamais la main (sur le load)
je reprecise aussi que les logiciels ou j'ai testé la chose ont le parametrage de fait pour transmettre un lf,cr ou les deux et un &1a en fin de fichier mais rien ni fait.
de plus si le PC1600 ce fout des cr en fin de ligne le 1360 lui ne laisse pas passer cela !!
Write to charognard   Post an answer  Top
Answer n° 4
--------
27/07/2007 @ 15:32
by charognard

Anonymous

visitor
suite et fin!
le cable utilisé et un cable null modem F/F avec l'adaptateur CE137T qui est censé resoudre le problème 5v/12v de l'interface RS232 du pc 1360/1600
Write to charognard   Post an answer  Top
Answer n° 5
--------
28/07/2007 @ 19:24
by aldweb

Anonymous

visitor
Salut charognard,

Et bien, je dois dire que je suis un peu sans réponse.

Il faut bien toujours, selon les pockets, jongler avec les paramètres stop bits, line ending (cr,lf), program ending code (%1a), data bits (7 ou 8), et baud rate (1200, etc...) dans les paramétrages du logiciel big PC.
Par contre, coté Pocket, je n'ai jamais cherché à bidouiller, demandant au logiciel big PC de s'adapter.
Est-ce lié à tes adaptateurs Sharp standards quand je n'en utilise que des bidouillés maison (comme expliqué dans cette page) ? ... un comble alors !

Tout ce dont je suis sur, pour le PC-1360, ce sont les paramétrages que j'ai mis dans Tera Term Pro :
- Baud rate = 1200
- Data = 8 bits
- Parity = none
- Stop = 1 bit
- Flow control = Xon/Xoff

Désolé de ne pas pouvoir t'aider plus que ça...

@+
aldweb
Write to aldweb   Post an answer  Top
Answer n° 6
--------
28/07/2007 @ 21:44
by charognard

Anonymous

visitor
merci pour ta reponse.
mais j'ai trouvé la solution, dans ma config avec l'adaptateur CE137T il faut que je mette un temps de latence entre caratere de 10ms au moins (500ms en lf) et là ça marche sauf pour le code &1A au je suis obligé de faire un break quand le chargement est fini.
sur ton site il y a un peek pour voir la version du PC1360 sur le mien ça donne 5
Write to charognard   Post an answer  Top
Answer n° 7
--------
29/07/2007 @ 13:21
by aldweb

Anonymous

visitor
Flûte, désolé de ne pas y avoir pensé, c'est effectivement un paramètre sur lequel jouer aussi, je l'ai oublié dans ma liste hier.

Si la réponse est 5, c'est que tu as un modèle de 3ème génération de ROM, donc la dernière, la plus optimisée... quoique, je n'ai jamais noté aucun dysfonctionnement ou différence de fonctionnement entre mes machines sous différentes versions de ROM.

@+
aldweb
Write to aldweb   Post an answer  Top
Answer n° 8
--------
29/07/2007 @ 20:40
by charognard

Anonymous

visitor
merci pour ton aide
Write to charognard   Post an answer  Top
active topic active   closed topic closed   Important! Important!   New New message   -   Correct Correct message   Close Close topic   Make sticky Make sticky
[]
Forum Topic  Forum 



 
^ Top ^